レコードの一括処理(Lightning)
Lightningモードで使用する場合、レコードの詳細画面で操作したボタンを、複数のレコードに対して実行することができます。
インシデント管理の承認依頼を例に、レコードの一括処理の進め方について説明します。
<目次>
レコードを一括で承認依頼する
1.アプリケーションランチャーで、[LMIS サービスオペレーション]をクリックします。
[イベント管理]タブ、[インシデント管理]タブ、[問題管理]タブなどオブジェクトごとのタブが表示されます。
2.一括処理を実施するオブジェクトのタブをクリックします。この例では、[インシデント管理]タブをクリックします。
オブジェクトのホーム画面が表示されます。
3.ビューの一覧を表示して、表示するレコードを切り替えます。
たとえば、リストから[私の未完了インシデント]をクリックすると、自身が所有者の未完了のインシデントが一覧で表示されます。
4.承認依頼を実施するレコードの[インシデント番号]の左のチェックボックスにチェックして、右上に表示されているボタンメニューから[承認依頼]ボタンをクリックします。
5.[承認依頼]の確認メッセージが表示されますので、[保存]ボタンをクリックします。
操作するボタン(例として、[承認]ボタンなど)によっては、入力項目が表示されますので、入力してください。
入力した内容は、すべての選択したレコードに共通で使用されます。
6.実行する件数と最終確認のメッセージが表示されますので、[OK]ボタンをクリックします。
7.インシデントの承認依頼が実施されます。
これで、レコードの一括処理は完了です。
注意事項
レコードの一括処理を実施した際に、以下のエラーが発生することがあります。
エラー内容
「このレコードを保存するときに問題が発生しました。このレコードを編集する権限がないか、このレコードが削除またはアーカイブされている可能性があります。システム管理者にお問い合わせください。」
発生原因
データの更新する件数が一定以上になり、トランザクションで発行できるクエリのガバナ制限に抵触した際に出力されます。
ガバナ制限の詳細については「よくある質問(FAQ) ガバナ制限について」を参照してください。
回避策
選択するレコードの数を減らし、再度実行してください。